Getting errror while running community-app(https://github.com/topcoder-platform/commu) in my machine

2 posts Thu, Mar 11, 2021 at 08:00 AM in General Development Discussions

I am getting bellow error while trying to set up community-app for participating a challenge.
Could you please help me on this. Please find the bellow error.

prebuild-install WARN install No prebuilt binaries found (target=14.15.4 runtime=node arch=x64 platform=darwin) TOUCH Release/obj.target/libvips-cpp.stamp CXX(target) Release/obj.target/sharp/src/common.o In file included from ../src/common.cc:27: ../src/common.h:82:20: error: no member named 'Handle' in namespace 'v8' bool HasAttr(v8::Handle<v8::Object> obj, std::string attr); ~~~~^ ../src/common.h:82:37: error: expected '(' for function-style cast or type construction bool HasAttr(v8::Handle<v8::Object> obj, std::string attr); ~~~~~~~~~~^ ../src/common.h:82:39: error: use of undeclared identifier 'obj' bool HasAttr(v8::Handle<v8::Object> obj, std::string attr); ^ ../src/common.h:82:56: error: expected '(' for function-style cast or type construction bool HasAttr(v8::Handle<v8::Object> obj, std::string attr); ~~~~~~~~~~~ ^ ../src/common.h:83:29: error: no member named 'Handle' in namespace 'v8' std::string AttrAsStr(v8::Handle<v8::Object> obj, std::string attr); ~~~~^ ../src/common.h:83:46: error: expected '(' for function-style cast or type construction std::string AttrAsStr(v8::Handle<v8::Object> obj, std::string attr); ~~~~~~~~~~^ ../src/common.h:83:48: error: use of undeclared identifier 'obj' std::string AttrAsStr(v8::Handle<v8::Object> obj, std::string attr); ^ ../src/common.h:83:65: error: expected '(' for function-style cast or type construction std::string AttrAsStr(v8::Handle<v8::Object> obj, std::string attr); ~~~~~~~~~~~ ^ ../src/common.h:84:37: warning: variable templates are a C++14 extension [-Wc++14-extensions] template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ^ ../src/common.h:84:48: error: no member named 'Handle' in namespace 'v8' template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ~~~~^ ../src/common.h:84:65: error: expected '(' for function-style cast or type construction template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ~~~~~~~~~~^ ../src/common.h:84:67: error: use of undeclared identifier 'obj' template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ^ ../src/common.h:84:84: error: expected '(' for function-style cast or type construction template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ~~~~~~~~~~~ ^ ../src/common.h:84:89: error: expected ';' at end of declaration template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ^ ; ../src/common.h:84:90: error: expected unqualified-id template<typename T> v8::Local<T> AttrAs(v8::Handle<v8::Object> obj, std::string attr) { ^ ../src/common.h:87:26: warning: variable templates are a C++14 extension [-Wc++14-extensions] template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ^ ../src/common.h:87:37: error: no member named 'Handle' in namespace 'v8' template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ~~~~^ ../src/common.h:87:54: error: expected '(' for function-style cast or type construction template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ~~~~~~~~~~^ ../src/common.h:87:56: error: use of undeclared identifier 'obj' template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ^ ../src/common.h:87:73: error: expected '(' for function-style cast or type construction template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ~~~~~~~~~~~ ^ ../src/common.h:87:78: error: expected ';' at end of declaration template<typename T> T AttrTo(v8::Handle<v8::Object> obj, std::string attr) { ^ ; fatal error: too many errors emitted, stopping now [-ferror-limit=] 2 warnings and 20 errors generated. make: *** [Release/obj.target/sharp/src/common.o] Error 1 gyp ERR! build error gyp ERR! stack Error:make` failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)
gyp ERR! stack at ChildProcess.emit (events.js:315:20)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:277:12)
gyp ERR! System Darwin 19.6.0
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /Users/vishnuk/Documents/Learning-workshop/Top-Coder/community-app/node_modules/sharp
gyp ERR! node -v v14.15.4
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
npm WARN notsup Unsupported engine for topcoder-react-lib@1.1.7: wanted: {"node":"~8.11.2","npm":"~5.6.0"} (current: {"node":"14.15.4","npm":"6.14.10"})
npm WARN notsup Not compatible with your version of node/npm: topcoder-react-lib@1.1.7
npm WARN notsup Unsupported engine for topcoder-react-utils@0.7.5: wanted: {"node":"~8.11.2","npm":"~5.6.0"} (current: {"node":"14.15.4","npm":"6.14.10"})
npm WARN notsup Not compatible with your version of node/npm: topcoder-react-utils@0.7.5
npm WARN draft-js-markdown-shortcuts-plugin@0.3.0 requires a peer of draft-js-plugins-editor@~2.0.0-rc.1 || 2.0.0-rc2 || 2.0.0-rc1 || 2.0.0-beta12 but none is installed. You must install peer dependencies yourself.
npm WARN draft-js-markdown-shortcuts-plugin@0.3.0 requires a peer of react@^15.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN draft-js-markdown-shortcuts-plugin@0.3.0 requires a peer of react-dom@^15.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN react-addons-css-transition-group@15.6.2 requires a peer of react@^15.4.2 but none is installed. You must install peer dependencies yourself.
npm WARN react-css-super-themr@2.3.0 requires a peer of react@^0.14.0 || ^15.0.0-0 but none is installed. You must install peer dependencies yourself.
npm WARN react-slick@0.15.4 requires a peer of react@^0.14.0 || ^15.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN react-slick@0.15.4 requires a peer of react-dom@^0.14.0 || ^15.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN slick-carousel@1.8.1 requires a peer of jquery@>=1.8.0 but none is installed. You must install peer dependencies yourself.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.20.8 install: (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.20.8 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/vishnuk/.npm/_logs/2021-03-11T07_56_25_669Z-debug.log

View: Threaded  |  Flat
+0

Comments

  • 24 posts Fri, Mar 12, 2021 at 09:25 PM

    Hi @vishnu-coder. Did you already try asking in the Discussion forum for the specific challenge you are working on? The copilot of the challenge will be able to provide more direct help.

    +0
Sign In or Register to comment.